EGATE IPv6 DSL Connectivity

Getting Enabled for IPv6

IPv6 service is not enabled by default on our DSL services. While IPv6 is rapidly maturing we wish to ensure there is no adverse affects to customers who do not wish to transition at this time.

To have your account enabled please email support@egate.net and request the service be added. Please allow up to two business days for the service to be active.

IPv6 Support

EGATE Networks currently only supports Cisco routers running recent IOS code for connecting to our IPv6 services; however, a wide range of IPv6 network stacks are reported to work without issue. EGATE will slowly add platforms to its supported list over time.

IPv6 Standard Setup

Each client will be provided with a /48 assignment which you will be advised of when your account is configured.

PPPoE customers will also be provided a /128 for a point to point link dynamically during each session.

CPE Configuration : Cisco Router with dhcpv6-pd Support

The following examples is from a Cisco 2811 running c2800nm-advipservicesk9-mz.124-22.T. The router has a built in DSL WIC in slot 2/0.

ipv6 unicast-routing
!
interface Loopback0
 description Loopback Address and useful to allow world to ping for Troubleshooting
 ipv6 address EGATE_PREFIX ::1/128
!
interface FastEthernet0/0
 description internal network, first subnet
 ipv6 address EGATE_PREFIX 0:0:0:1::/64 eui-64
 no ipv6 nd ra suppress
!
interface FastEthernet0/1
 description internal network, second subnet
 ipv6 address EGATE_PREFIX 0:0:0:2::/64 eui-64
 no ipv6 nd ra suppress
!
interface ATM0/2/0
 description ADSL WIC Connected to EGATE DSL Line
 no ip address
 no atm ilmi-keepalive
 dsl enable-training-log 
!
interface ATM0/2/0.1 point-to-point
 pvc 0/35 
  pppoe-client dial-pool-number 2
 !
interface Dialer2
 description EGATE PPPoE Session
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 encapsulation ppp
 dialer pool 2
 ipv6 address autoconfig
 ipv6 enable
 ipv6 dhcp client pd EGATE_PREFIX
 no cdp enable
 ppp pap sent-username your_username@egatedsl.ca password your_egate_password

CPE Configuration : Cisco Router with no dhcpv6-pd Support

The only difference between the above examples and this one is that it is know what /48 has been assigned by EGATE to the customer in advance, and we need to configure the interface addresses manually. In this example, the customer has been assigned 2001:4900:123::/48 for use in their network.

ipv6 unicast-routing
!
interface Loopback0
 description Loopback Address and useful to allow world to ping for Troubleshooting
 ipv6 address 2001:4900:123::1/128
!
interface FastEthernet0/0
 description internal network, first subnet
 ipv6 address 2001:4900:123:1::/64 eui-64
 no ipv6 nd ra suppress
!
interface FastEthernet0/1
 description internal network, second subnet
 ipv6 address 2001:4900:123:2::/64 eui-64
 no ipv6 nd ra suppress
!
interface ATM0/2/0
 description Bell DSL
 no ip address
 no atm ilmi-keepalive
 dsl enable-training-log 
!
interface ATM0/2/0.1 point-to-point
 pvc 0/35 
  pppoe-client dial-pool-number 2
 !
interface Dialer2
 description EGATE PPPoE Session
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 encapsulation ppp
 dialer pool 2
 ipv6 address autoconfig
 ipv6 enable
 no cdp enable
 ppp pap sent-username your_username@egatedsl.ca password your_egate_password

CPE Configuration : FreeBSD

An unsupported example for using FreeBSD to connect to EGATE DSL with IPv6 is provided here

 

© 2005 E-Gate Communications Inc. All Rights Reserved.